Phones

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 20:04 CDT

Monitoring

All phone lines should now be operational. If you are having difficulty, please enter a service desk ticket. -JB
Posted Jul 30, 2025 - 16:50 CDT

Update

Services are in the process of being restored. At this time the McDaniel and Hall Center facilities should be operational. All sites should be operational shortly. -JB
Posted Jul 30, 2025 - 14:23 CDT

Update

We are continuing to work on a fix for this issue. -JB
Posted Jul 30, 2025 - 13:00 CDT

Update

We are continuing to work on a fix for this issue. -JB
Posted Jul 30, 2025 - 11:14 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 30, 2025 - 10:05 CDT

Identified

The issue has been identified. No estimated time to repair as of yet. -JB
Posted Jul 30, 2025 - 08:38 CDT

Investigating

We are currently experiencing issues with phones. We are working on the issue and will update once phones are back up.-jsz
Posted Jul 30, 2025 - 07:37 CDT
This incident affected: Internet, Network, & Telephone (Telephones).