Google Issues
Incident Report for Escambia County School District
Resolved
Google is showing all systems are now operational; you may need to refresh your page.
-LC
Posted Apr 12, 2021 - 11:46 CDT
Update
Per the Google Status page, They are continuing to investigate the outage: The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.
-LC
Posted Apr 12, 2021 - 10:26 CDT
Investigating
According to the Google Status Dashboard the following are having issues: Google Drive. Docs, Sheets, Slides, and Classroom

4/12/21, 8:36 AM
We're investigating reports of an issue with Google Drive. We will provide more information shortly. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

Affected user are unable to create new documents.

-LC
Posted Apr 12, 2021 - 09:22 CDT
This incident affected: Email, Calendar, & Collaboration (Google Classroom, Google Apps Drive, Google Apps Docs, Google Apps Sheets, Google Apps Slides).