North End Schools Down

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 07:42 CST

Investigating

Jim Allen, Molino Park, Ernest Ward, Bratt and Northview are without network service. We are investigating a suspected fiber cut. No ETA on repairs at this time. -JB
Posted Nov 30, 2025 - 19:42 CST
This incident affected: Internet, Network, & Telephone (Internet).