Board Docs Still Having Issues

Incident Report for Escambia County Public Schools

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 12:36 CDT

Monitoring

Diligent indicates that they have resolved the issue with Board Docs. We will leave the status at "Monitoring" for a while. -JB
Posted Apr 28, 2026 - 14:33 CDT

Identified

Diligent continues to work on the issue, https://status.diligent.com/incidents/207qkmvtztbf
Posted Apr 28, 2026 - 10:36 CDT
This incident affected: Other.