Fiber Cut Longleaf/Bellview Area

Incident Report for Escambia County Public Schools

Resolved

All sites are now operational.
Posted Mar 19, 2025 - 07:50 CDT

Update

George Stone Technical College is now operational. -JB
Posted Mar 18, 2025 - 17:48 CDT

Monitoring

Bellview ES, Bellview MS, Longleaf ES are up. We are still waiting on Success Academy and George Stone Technical College. They should be up soon. -JB
Posted Mar 18, 2025 - 17:35 CDT

Identified

Crews are pulling fiber this morning. We hope to have a repair today.
Posted Mar 18, 2025 - 08:59 CDT

Update

Crews are onsite to evaluate. We do not yet have an estimated time to repair. -JB
Posted Mar 17, 2025 - 10:22 CDT

Update

Crews will be onsite Monday. We will not attempt a repair this weekend. -JB
Posted Mar 15, 2025 - 06:52 CDT

Investigating

We’ve lost connectivity to Pine Forest, George Stone, Success Academy, Longleaf, Bellview ES & Bellview MS. We are investigating a possible fiber cut. -JB
Posted Mar 14, 2025 - 18:17 CDT
This incident affected: Internet, Network, & Telephone (Internet, Telephones).