Potential Issue with Google Hangouts/Meet
Incident Report for Escambia County Public Schools
Resolved
Per Google, this incident has been resolved. JB
Posted May 19, 2020 - 13:29 CDT
Identified
From Google
Status: Service disruption
May 19, 2020 8:50:00 AM PDT

We're aware of a problem with Google Hangouts affecting a majority of users. The affected users are unable to access Google Hangouts. We will provide an update by May 19, 2020 9:50:00 AM PDT detailing when we expect to resolve the problem. Please note that this resolution time is an estimate and may change.
Posted May 19, 2020 - 12:24 CDT
This incident affected: Email, Calendar, & Collaboration (Google Meet).