Reduced Internet Bandwidth
Incident Report for Escambia County Public Schools
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 19:53 CDT
Investigating
One of our internet providers is down. We are routing around the issue until it is resolved. We do not expect an impact to services. -JB
Posted Apr 01, 2024 - 13:35 CDT
This incident affected: Internet, Network, & Telephone (Internet).